How To: Install Fedora Core 6 On Intel DG965SS Motherboard

I decided to take the plunge and start playing around with dual core technology, so I went down to the local store and picked up a new CPU, RAM, and motherboard. However, what I discovered was that it can actually be quite difficult actually installing

Linux to what I had purchased, due to the newness of the technology. While support for dual core CPUs has been around for a while, support for some of the more recent motherboards has not, and mine was one of them. So, I could wait for broader support in a few months, or see what I could do now.

First, the reference information — the hardware I used.

* Intel Core 2 Duo Processor E6600
* Intel Classic Series Desktop Board DG965SS
* Kingston KVR533D2N4K2/1G (2x 512 MB)
* Western Digital 74 GB SATA Raptor WD740ADFD
* Antec TruePower 2.0 TPII-430
* JVC XJ-HD166S ATAPI DVD-ROM

Live isn’t so live, after all.

My plan was to battle-test this system with a few different Linux distributions, and then transition to testing Windows, but alas — my plans were not to be. I couldn’t even successfully boot up the live CDs I had! I’ve reproduced the error messages below, for the people searching for an answer.

If I tried to boot up Knoppix 5.0 DVD (2006-06-01-EN), I would get this error:

Can't find KNOPPIX filesystem, sorry.
Dropping you to a (very limited) shell.
Press the reset button to quit.

If I tried to boot the Ubuntu 6.10 “Edgy Eft” live CD, I would get this error:

BusyBox v1.1.3 (Debian 1.1.1.3-2ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off

If I tried to boot the CentOS 4.4 live CD, I wouldn’t even get an error message — it would just reboot when I tried to select an option.

The interesting thing about the above is that the file system for live CDs largely lives on the CD itself. Hence, if it couldn’t read it as in the above, then for some reason, the DVD drive wasn’t accessible. After doing a little research online, I discovered that the motherboard was relatively new, and did some rather funky things with the handling of the IDE devices. Hence, the computer would start to boot off the optical drive, but when it came time to load up a kernel and actually boot the system, the computer no longer knew how to access the drive! This all resulted from a lack of Linux support for the new motherboard architecture from Intel. Haven’t Linux developers built that time machine yet to get future architectures into old kernels? (Note that Windows would have similar problems; if I didn’t have an up to date Windows install CD or the driver disk, I would be out of luck.)

New hardware? Please stand by, support will be added momentarily…

Linux developers have a reasonably quick turnaround time on these things, and have, in fact, added support to the kernel. Unfortunately, they added it to the most recent kernel — 2.6.18. In CentOS 4.4 (as well as Red Hat Enterprise 4.4), this is 2.6.9-39. In Knoppix 5.0 is 2.6.17. In Ubuntu Edgy Eft, it’s 2.6.17. I would need to wait for the next release before getting support for the 965 chipset. Fortunately for me, Fedora Core 6 was released with the 2.6.18 kernel, meaning that I could use that instead. Being that I didn’t really feel like re-authoring my own custom live CD, I went with that, and will just have to wait for future releases on the others.

The devil is in the details.

I downloaded Fedora Core 6 for x86_64. I’m fairly certain that the i386 version would install in much the same manner, but decided that I might as well use the 64-bit version. I put in the DVD and booted up the computer.

However, it brought up a text-mode window to select language, keyboard, and installation method: something had gone wrong, because in a normal install, the full graphical environment would have been displayed. Upon selecting an installation method of “Local CDROM”, the installer reported the error “No driver found” — looks like I had some work to do.

First, I rebooted and struck F2 to get into the BIOS. Under the “Advanced” tab, “Drive Configuration”, I set “Configure SATA as” to “AHCI”. I then exited, saving changes.

Next, I rebooted with the the install DVD in the drive. When the message came up “To install or upgrade in graphical mode, press the <enter> key.”, I didn’t just hit enter — instead, I typed the following line:

linux all-generic-ide pci=nommconf

This is the magic trick. After skipping the media check, the full graphical environment came up at that point, and I could install as per normal. I did so, and the computer rebooted after installation.

So close, I can taste it!

The computer boots up, and the Internet connection was recognized straight away. The resolution was set to 800×600, so I went to System->Administration->Display, and clicked on the Hardware tab. I changed the monitor to “Generic CRT Display/Monitor 1280×1024″, and then I could set the resolution to (naturally) 1280×1024. System updates worked fine, and programs launched correctly. I could surf the web without issue (except for flash support, which is a whole other problem I won’t address here).

However, there was something wrong…the optical drive no longer worked! I could put in a CD or DVD, and they wouldn’t be recognized by the operating system, despite having worked fine for the install process. The problem here is in GRUB, the Linux bootloader. While the install had correctly added pci=nommconf to the loader, it had neglected to include the all-generic-ide tag.

I edited /etc/grub.conf as root, and changed the line…

kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 pci=nommconf rhgb quiet

…to…

kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 all-generic-ide pci=nommconf rhgb quiet

I needed to re-install GRUB, with grub-install /dev/sda1. A reboot later, and things worked fine.

Success!

So yes, Virginia, it is possible to install Linux on this wonky motherboard. What’s more, since the support is in the kernel (and far better people than myself are slavishly hacking away at it), it’s quite likely that distributions will support this out of the box in the future without special handling. I haven’t had any issues with this set up yet, and it runs in 64-bit mode to boot.

Some closing thoughts…

* The problems I experienced were largely a result of the IDE channel handling of the chipset. If I had an SATA optical drive, I could probably have gotten up and running on Fedora Core 6 without any extra futzing. This also may have gotten Ubuntu to install as well.
* This also means that if you have, say, ATA drives (not SATA), you may experience a whole host of other problems.
* Ubuntu “Edgy Eft” should have some backports built into it to handle the Intel 965 chipset, however, I couldn’t get them to work. It’s feasible that this CD could boot on an ATAPI optical drive, if given the right options.
* While these problems will probably go away in new releases, it’s not guaranteed. The chipset will at least be better supported.
* I’m not looking forward to the Windows installation. The chipset claims that I should be fine with Windows XP SP2 or Windows Media Center Edition. Only time will tell.

Source : http://www.blindedbytech.com/2006/11/10/how-to-install-fedora-core-6-on-intel-dg965ss-motherboard/

powered by performancing firefox

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s